Daily Archives: May 8, 2019

阿里云升级PHP7

PHP 7.1

阿里云 CentOS 7.6 默认 PHP 5.5,最新版 WordPress 要求 PHP 5.6+,所以需要升级。目前 7.2 是最新版,为稳定考虑选择了 7.1

首先查看已安装 PHP ,并删除;然后添加一下源,并安装新版,省却下载编译各种折腾。

yum list installed | grep php
yum remove php-common
rpm -Uvh https://mirror.webtatic.com/yum/el7/epel-release.rpm 
rpm -Uvh https://mirror.webtatic.com/yum/el7/webtatic-release.rpm
yum install php71w php71w-opcache php71w-fpm php71w-mysqlnd

Continue reading